ubuntu22 安装python3-dev()

使用apt安装python-dev时报错,更换软件源无法解决。

首先确定python版本(大版本号,我的是3),然后使用python3-dev代替python-dev。

使用aptitude解决问题:

1.安装 aptitude

sudo apt install aptitude

2.然后用aptitude安装python3-dev

aptitude的百科:aptitude(Debian系统的包管理工具)_百度百科

aptitude的基本命令和apt相同,只需把apt换成aptitude即可。

sudo aptitude install python3-dev 

遇到依赖包冲突时aptitude会提供几个方案给你选择,第一次尝试建议全选Y。

如果第一次安装不成功,再进行第二次尝试,这次要细看给出的选项,如果python3-dev的状态是未安装,操作是维持现状,则需要选N其它选项全选Y。

验证python-dev是否安装成功

进入/usr/include/python3.8(python版本不同会有区别),如果有python.h则安装成功。

—END—

————————

使用apt安装python-dev时报错,更换软件源无法解决。

首先确定python版本(大版本号,我的是3),然后使用python3-dev代替python-dev。

使用aptitude解决问题:

1.安装 aptitude

sudo apt install aptitude

2.然后用aptitude安装python3-dev

aptitude的百科:aptitude(Debian系统的包管理工具)_百度百科

aptitude的基本命令和apt相同,只需把apt换成aptitude即可。

sudo aptitude install python3-dev 

遇到依赖包冲突时aptitude会提供几个方案给你选择,第一次尝试建议全选Y。

如果第一次安装不成功,再进行第二次尝试,这次要细看给出的选项,如果python3-dev的状态是未安装,操作是维持现状,则需要选N其它选项全选Y。

验证python-dev是否安装成功

进入/usr/include/python3.8(python版本不同会有区别),如果有python.h则安装成功。

—END—